Beberapa Alasan Kamu harus Update Versi PHP

PHP saat ini merupakan salah satu bahasa pemograman yang populer untuk build aplikasi berbasis web, menurut w3tschs , 78,9% situs web di kembangkan menggunakan bahasa pemrograman PHP. Saat saya nulis artikel ini, php yang paling banyak di gunakan adalah php versi 5, untuk detail sebarannya seperti gambar di bawah.

Barusan saya selancar di webistenya WordPress, tepatnya di alamat https://wordpress.org/about/stats/, ternyata di ekosistem WordPress, PHP versi 5 masih banyak digunakan.

Oke, setelah baca data grafik di atas… kita lanjut ya…, sekarang kita baca data untuk life cycle dari PHP :

Supported PHP Versions for WordPress

Dari data di atas, kita lihat bahwa untuk PHP versi 5.6  dukungan keamanan cuma sampai Dec 2018, jadi bagi kamu yang masih memiliki php versi 5.6 atau malah di bawah versi 5.6, segera update ya…, karena dengan menggunakan versi php yang sudah tidak ada dukungan keamanan, akan mengancam kemanan aplikasi yang kamu gunakan.

Beberapa alasan, kenapa untuk adopsi PHP versi baru rendah, karena ada beberapa faktor :

  • Alasan pertama yang sering saya denger dari customer atau pelanggan yang bermigrasi ke ArenaStreaming.Com, adalah bawah mereka tidak mengetahui mengenai versi php yang mereka pakai.
  • Butuh waktu bagi pengembang untuk memperbarui kode mereka untuk mendukung versi PHP yang lebih baru.
  • Tidak hanya membutuhkan usaha dan waktu untuk memperbarui kode program, update juga memerlukan pengujian ekstensif untuk memastikan kompatibilitas dengan plugin, themes dll.
  • Pengembang biasanya stuck ketika berhadapan dengan pihak ketiga, mereka tidak mau mengahabiskan resource untuk memperbarui kode program.
  • Dll.

Beberapa Alasan Kamu harus Update Versi PHP

Berikut akan saya uraikan beberapa alasan kenapa kamu harus update Versi PHP, selain faktor keamanan ada faktor lain yang mungkin bisa menjadi pertimbangan, kenapa kita harus Update Versi.

  • Keamanan

Salah satu faktor penting untuk Update Versi PHP adalah karena faktor keamanan, dengan Update versi PHP terbaru akan memastikan aplikasi berjalan aman dan dapat dukungn & patch secara rutin dari celah keamanan yang timbul. Untuk PHP versi 5.4 sudah tidak mendapatkan patch sejak 2015. dan PHP 5.5 sudah tidak mendapatkan patch sejak 2016. Menurut CVE Details, tahuan 2016 merupakan tahun di mana banyak lubang di keaman PHP. lebih dari 100 masalah di laporkan, meiluti DoS, Code Execution, Overfole, Memory Corruption, Xss Dll.

  • Performance

Dengan di rilisnya PHP 7, ada peningkatan performa yang luar biasa !, jadi kamu yang berkutat di PHP 5, segera Update :), lihat hasil benchmarks

  • Support

Dukungan adalah alasan kamu harus update ke versi PHP yang terbaru dan ada support nya.

  • Fitur baru untuk developer

Beberapa perubahan dengan PHP 7 dan 7.1 meliputi:

Combined comparison operator

Null coalesce operator

New type hinting

Anonymous classes

Nullable types

Iterable and void returns

Multi-catch exception handling

Keys usable in lists

More negative string offsets

Number operators and malformed numbers

HTTP/2 server push

Oke… ya… sampai sini dulu nulisnya.., kapan kapan di sambung lagi.

Leave a Reply

Your email address will not be published. Required fields are marked *

five + 16 =